Path

ez projects / paradoxpdf / forum / general / can i add images to my pdfs?


Can i add images to my pdfs?

You need to be logged in to post messages in the forums. New users may register here.

Carlos Revillo

Member since:
31 January 2007

Posts: 53

Friday 17 April 2009 2:46:48 pm

Hi. I'm having problems trying to add images to my pdfs.
First, i was trying something like



  <img src={"logo.png"|ezimage} />




but paradox.log said that quote was expected after src= attribute.

So, i just decided to test with an absolute url.



  <img src="/design/mysite/images/logo.png" />




but still no luck... am i doing something wrong?

Regards.

Twitter: @crevillo
Skype ID: crevillo1976
http://www.tantacom.com
eZ Diff Squad member

Up

Karnichi Mohamed

Member since:
09 October 2006

Posts: 78

Friday 17 April 2009 3:12:59 pm

Hi carlos,

Of course you can add any image to your pdf. Do you use the last version of paradoxpdf ?
If so, Would you please active the debug, clear all tmp file in extension/paradoxpdf/tmp
Then try to export a pdf then send me the content of the temporary xhtml file in the extension/paradoxpdf/tmp.

http://www.amiralweb.com Certified eZPublish Expert

Up

Carlos Revillo

Member since:
31 January 2007

Posts: 53

Friday 17 April 2009 3:26:10 pm

Ok. I'll do that test asap, but now i'm a hurry. I've just tried a tricky. Tricky is trying to load the image from my css, as a background. And it works!.

I will post the xhtml here anyway. Thank you.

Twitter: @crevillo
Skype ID: crevillo1976
http://www.tantacom.com
eZ Diff Squad member

Up

Karnichi Mohamed

Member since:
09 October 2006

Posts: 78

Friday 17 April 2009 4:21:53 pm

Ok!

By default paradoxpdf handles relative images and css uri.
But Just notice that the simplest way to have links and images working in your pdf, is to set the absolute uri to them.
The XHTML rendrer will try to load them through HTTP. By this way paradoxpdf can handle ressources stored in Cluster mode. If you choose this way, please make sure that your server firewall configuration enables connections through the port 80


Enjoy

http://www.amiralweb.com Certified eZPublish Expert

Up

Lars Eirik Roenning

Member since:
20 July 2009

Posts: 35

Thursday 15 October 2009 3:18:24 pm

Hi I am having problems with displaying my images.
All other content shows up, but no images.
I have tried to override my article.tpl sucessfully.

When i try to do {attribute_view_gui attribute=$node.data_map.image image_class=medium} nothing happens.

Any ideas?
Do i have to override images as well to get the images included in the pdf?
Up

Karnichi Mohamed

Member since:
09 October 2006

Posts: 78

Thursday 15 October 2009 4:58:04 pm

Hi Eirik,


You can simply enable debug (see paradoxpdf documentation), and check the resulting html file or send me both the debug output and the resulting xhtml.

Thanks

http://www.amiralweb.com Certified eZPublish Expert

Up

You need to be logged in to post messages in the forums. New users may register here.