Path

ez projects / ezsurvey_ezp4 / forum / general / a little warning on the fie...


A little warning on the field _mandatory_hidden_

You need to be logged in to post messages in the forums. New users may register here.

Luca Realdi

Member since:
29 April 2010

Posts: 2

Thursday 30 June 2011 5:13:41 pm

The field



<input type="hidden" name="{$prefix_attribute}_ezsurvey_question_{$question.id}_mandatory_hidden_{$attribute_id}" value="1" />



could not be parsed by PHP with Suhosin-Patch.

Suhosin does indeed have http://www.hardened-php.net/suhos...on.html#suhosin.post.max_name_length with a default of 64.
And the field (e.g. ContentObjectAttribute_ezsurvey_question_52698_mandatory_hidden_373861 ) could exceed the 64 characters.



The solution to all the problems of the world? Clear the cache!

Up

Bjørn Reiten

Member since:
22 February 2008

Posts: 39

Thursday 30 June 2011 5:26:58 pm

My experience is that you need to disable or configure Suhosin especially, since many of the limits for postvariables are exceeded here, when you're using the survey extension.
Up

Gaetano Giunta

Member since:
01 May 2012

Posts: 268

Thursday 30 June 2011 6:15:06 pm

Might make a nice info page in the ez.no docs / blog post on sghare.ez.no, if we get most of the details of problems with suhosin straight...

Principal Consultant International Business
Member of the Community Project Board

Up

You need to be logged in to post messages in the forums. New users may register here.